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TUTORIEL FragMotion 1.2.2  
 - par Giuliani (Terrier) - 

 

 

FragMotion est un logiciel complet qui permet à la fois de modéliser en 3D, de peindre des textures et d'animer ses modèles. 
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A. Paramètres et interface 
 

Avant toute chose, dirigez-vous vers Edit -> Edit Preferences. 

Une liste apparait et vous avez la possibilité de modifier certaines options pratiques 

afin d'arranger l'espace de travail comme bon vous semble: 

 

_ VERTEX   = pour modifier la taille des vertex 

_ BONE  = pour modifier la taille des bones  

_ GRID  = Affichage de la grille ou non  

_ VIEW  = la couleur du fond (optez pour du sombre parce que le Wireframe est en 

     blanc), et augmenter la couleur ambiante (optez pour le blanc). 

     Bizarrement quand je modifie le LAYOUT, rien ne se passe..? 

  

 

 

 

 

 

 

 

 

 

 

 

 

Pour modifier les fenêtres d'affichage, je dois passer par la barre d'options en haut VIEW -> Layout -> 2left + 1Right, organisez le viewport en 

fonction de vos préférences. 

 

Pour modifier la caméra dans un viewport il suffit de cliquer sur les icônes jaunes, 

elles correspondent à Vue de gauche, de droite, du dessus, du dessous, de face, de dos et en perspective (3D)  

  
A leur droite, les options d'affichage du mesh, en Wireframe (encadré), brut sans texture, sans texture lissé et la dernière AVEC texture. 
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1. Les commandes : 

 
Clic GAUCHE  = SELECTION 

Molette              = ZOOM 

Clic DROIT maintenu = ROTATION de la caméra autour du modèle (le curseur doit rester à l'intérieur du cercle vert ci-dessous) 

 

 
 

Clic Molette    = Activer le Viewport souhaité 

Clic Molette maintenu   =  DEPLACEMENTS LATERAUX 

Clic Molette maintenu + CTRL  = ZOOM au plus prés (et plus rapide en déplaçant la souris de droite à gauche 

 

ALT + R       = Recentrer la vue 



4 

 

CTRL + clic Droit      = Options d'affichage 

CTRL + A       = Tout Sélectionner 

CTRL + MAJ +N      = Désélectionner 
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2. Les panels d'outils: 
 

 

_Animations/ Skeleton:  

             qui regroupera les futures animations créées mais aussi d'autres options 

  via des onglets en bas de fenêtre: 

 

 - Skeleton qui affiche l'arborescence des bones 

 - Model qui affiche toutes les options du mesh 

 - Texture qui affiche les textures du mesh 

 - Schema qui regroupe l'intégralité des informations sur le mesh entier 

      (texturé et animé) 

 

 

_Properties:  

 qui permet de modifier avec précision les valeurs de chaque objet 

 (position, nom, bone, rotation etc...) 

 

 

 

_ Tools:  

 Fenêtre qui regroupe tous les outils nécessaires. 

 Ici, nous ne verrons que les fonctions: 

 _ SELECT 

 _ CREATE 

 _ BONE 

 _ et SKELETAL ANIMATION 

 

 

 

 

 

Sachez que si par erreur vous fermiez un de ces panels, vous pouvez toujours le 

rouvrir dans WINDOWS-> choisissez le panel et cliquez sur SHOW. 
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B. LE SKINNING 
 

1. Charger le Mesh : 
Il va falloir importer votre modèle 3D (mesh) dans un 1er temps.  

FragMotion est très complet et intègre un très grand nombre de formats d'importation. 

Mais avant de faire quoi que ce soit , assurez-vous que les articulations de vos modèles 3D (intérieur et extérieur des coudes, les genoux , les épaules et 

les doigts) ont bien été conçu au mieux comme l'une des 2 premières illustrations ci-dessous. 

Sinon refaites-les! Car vos animations ne seront pas propres (cf. la 3éme illustration) J'ai déjà refait mon mesh 3 fois en rédigeant ce tuto... 

 



7 

 

 

Pour réaliser ce tuto, j'ai modélisé mon personnage avec 3D Studio Max, après plusieurs essais, j'ai travaillé sur 2 formats d'exportation le .smd et le .X: 

 

Δ J'ai exporté mon modèle 3D en .smd depuis 3D Studio Max. Le modèle est à l'endroit dans FragMotion, mais il est inversé dans RealmCrafter!  

La 1ere fois je m'en suis rendu compte après l'avoir animé, j'ai du sélectionner le mesh dans le panel Model (le mesh entier passe en surbrillance 

rouge) et en même temps dans le panel Tools, Select j'ai également sélectionné tous les bones puis dans Transform/ Transform Options j'ai 

activé la case Rotate,  Y = 180°.  

Après Export, ça fonctionne nickel dans RC. 

 

Δ J'ai exporté mon modèle 3D en .X depuis 3D Studio Max. Le modèle est inversé dans FragMotion donc bien à l'endroit dans RealmCrafter, par 

contre il a subit un effet MIROIR sur l'axe X dans FragMotion.  
Sélectionner le mesh dans le panel Model (passe en surbrillance rouge) puis dans Transform -> Mirror Mesh Selection -> X-Axis. 

CTRL + MAJ +N pour désélectionner 

 

Au final j'ai décidé de continuer à travailler avec le .X, à part l'effet Miroir qui se corrige très rapidement, je n'ai pas eu d'autres inconvénients 

dans RC. 

 

 

 

ATTENTION: 

Quand vous importez un mesh dans FragMotion, ce dernier a pour habitude de lui attribuer directement un bone (sur le point de pivot du mesh). 

Le bone a la forme d'une sphère bleue, vous pouvez pas le louper. Dans le Panel TOOLS (en bas à droite), si vous n'êtes pas déjà sur SELECT, 

cliquez sur le panneau déroulant, SELECT-> SELECT BONE, cliquez sur le bone et Supprimez-le (Suppr). 

 

Attention encore, c'est pénible mais FragMotion ne rafraichit pas automatiquement la fenêtre, donc parfois vous aurez l'impression qu'il n'a pas 

exécuté la tâche demandée comme supprimer le bone, faites une petite rotation sur le mesh avec le click droit et la fenêtre se sera rafraichie.  
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2. Créer le squelette : 
Avant de commencer, je tiens à préciser que je ne prétends pas que ce soit la meilleure technique de travail, c'est juste la mienne! 

J'ai toujours tout appris tout seul (3D, texture, animation) et j'aime partager ce que je découvre seul.  

Libre à vous de vous en servir comme base et de la faire évoluer par la suite.  

 
RealmCrafter Standard conseille 20 bones mais supporte jusqu'à 37 bones maximum.  

Pour RC, je conçois mes squelettes de cette façon. Mon squelette compte 20 bones en tout, mais vous devriez en avoir 16. 

(Mes persos combattent à mains nues, j'utilise 2 bones  pour animer chaque main.) 
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a). Un squelette en 20 bones. 
 

Je débute la 1ére partie toujours par la vue de face, dans le panel TOOLS -> CREATE -> BONE: 

_ Je clique Gauche au niveau de l'entrejambe pour positionner le 1er Bone Pelvis, X= 0 Y=60 et Z= 0 sur mon perso 

_ Au niveau du nombril je pose le 2éme Pin, X=0 

_ Puis au niveau du Thorax je pose le 3éme Chest, X=0 

_ Et enfin à la frontière entre le cou et la tête un 4eme Head, X=0 

 

 
 

Une fois que vos bones sont placés, il faut les positionner correctement, on passe donc en vue de Profil (gauche ou droite). 
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À droite dans TOOLS -> BONE ->  BONE WIDGET: 

 
Une petite boite à outil volante apparait, Nous procéderons en 3 étapes, respectez l'ordre: 

1. On clique sur l'icône Os (Select Bone) et on sélectionne le bone Pelvis 

 
 

2. On clique sur l'icône Move Object à côté, une couleur se met en surbrillance sur le triangle 

 
3. Cette couleur correspond à celles affichées sur votre bone: 
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_ il y a un trait rouge qui pointe vers le haut (qui indique la hauteur axe Y) 

_ et un trait vert qui pointe vers l'arrière (ici il indique la profondeur axe Z) 

 

Cliquez sur la case verte, et vous pourrez déplacer votre bone de droite à gauche. 

L'axe est restreint donc vous ne pourrez pas faire de boulette 

 

 
 

Si vous souhaitez l'ajuster sur la hauteur, refaites dans l'ordre: 

Select Bone, Move Object, Case Rouge et vous pourrez déplacer votre bone de haut en bas uniquement. 

 

Ce principe s'adapte à la vue affichée dans le viewport, si vous basculer en vue de face ou en vue de haut, les axes changeront également donc fiez-vous aux 

couleurs des axes et respectez bien l'ordre pour éviter d'avoir à vous y reprendre 10 fois (ça peut être pénible à la longue ^^): 

 

 

Select Bone -> Move Object -> Case Couleur 

 

 

RC exige des noms de bone précis: si vous souhaitez attacher des gubbins (sets d'armure, armes, boucliers etc...) à vos persos. 

Les Gubbins ne sont pas obligatoires, dans ce tuto je ne les utilise pas, ajustez en fonction de vos besoins. Le bone Head est obligatoire par contre. 
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    1. Head (pour les cheveux, casque etc...) 

    2. Chest (pour l'armure) 

    3. R_Shoulder 

    4. L_Shoulder 

    5. Pelvis (pour les montures) 

    6. R_Forearm 

    7. L_Forearm 

    8. R_Hand (pour les armes et boucliers) 

    9. L_Hand 

    10. R_Shin 

    11. L_Shin 

  

 

 

 

   Dans FragMotion, pour renommer vos bones, cliquez dans le panel Properties à droite. 

   Dans Name, cliquez sur Bone et renommez-le. 

 

 

b). Donc après avoir renommé ces 1ers bones, on reprend afin de créer les jambes. 
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Pour cette partie je passe en vue de profil; ensuite à droite dans TOOLS -> SELECT ->  SELECT BONE: 

  _ On clique sur le bone à partir duquel on va repartir donc ici, Pelvis (le bassin, c'est le 1er que l'on a créé) 

Le bone passe donc en rouge, on va commencer par la jambe droite (gauche face à nous) puis TOOLS -> CREATE -> BONE: 

  _ Je clique Gauche au niveau du fémur, 1er Bone (R_Leg) 

  _ Je descends au genou et je pose le 2eme bone (R_Knee) 

  _ Enfin je descends jusqu'à la cheville (R_Foot) 

 

La jambe droite est faite. À droite dans TOOLS -> SELECT ->  SELECT BONE: 

  _ On reclique sur le bone Pelvis  

Le bone repasse donc en rouge et on fait exactement la même chose que pour la jambe droite mais à gauche cette fois TOOLS -> CREATE -> BONE. 

Et on renomme les 3 bones de cette façon: 

  _ Fémur gauche, (L_Leg) 

  _ Genou gauche (L_Knee) 

  _ Cheville gauche (L_Foot) 

Pour plus de précisions et de symétrie, Dans le panel Properties, option TRANSFORM, cliquez sur X,Y ou Z et insérez-y les même données de POSITION 

ATTENTION: la valeur X de la jambe Droite est positive (ex: X: 4,0) donc celle de la jambe gauche sera négative (donc: X:-4,10) 
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c). Maintenant les bras. 

je repasse en vue de face ; à droite dans TOOLS -> SELECT ->  SELECT BONE: 

  _ Je clique sur le bone Chest (au niveau du Thorax) 

  ATTENTION: Vous pouvez également faire repartir du le bone du cou Neck 

 

Le bone passe donc en rouge, on va commencer par le bras droit (gauche face à nous) TOOLS -> CREATE -> BONE: 

  _ Je clique Gauche au niveau de l'épaule, 1er Bone (R_Shoulder) 

  _ Je continue au niveau du coude, 2eme bone (R_Elbow) 

  _ Je vais jusqu'au poignet 3eme bone (R_Hand) 

 

On passe au bras gauche donc TOOLS -> SELECT ->  SELECT BONE: 

  _ On reclique sur le bone Chest 

Le bone repasse donc en rouge et on fait exactement la même chose que pour le bras droit, TOOLS -> CREATE -> BONE. 

  _ Epaule gauche, 1er Bone (L_Shoulder) 

  _ Coude gauche, 2eme bone (L_Elbow) 

  _ Poignet gauche 3eme bone(L_Hand) 
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d). Enfin, on termine le squelette par les mains. Là encore, ça va dépendre de la conception de votre mesh, vous pouvez en mettre moins. 

1 seul bone est nécessaire pour tenir les objets dans la main. 

Je modélise le pouce et les doigts collés de façon à pouvoir les animer séparément. 

Ensuite suivez la procédure habituelle pour chaque doigt: 

  TOOLS -> SELECT ->  SELECT BONE: 

  _ On clique sur le bone R_Hand (poignet) 

 

  TOOLS -> CREATE -> BONE: 
  _ je place 2 bones pour l'ensemble des doigts R-Fingers et R_Fingers_end (c'est lui qui pilotera la main, l'autre ne servira que de charnière) 

Le pouce restera immobile, l'idéal c'est de la modéliser à moitié-fermé 

 

Et on refait la même chose à gauche. 

 



16 

 

3. Attacher le squelette au mesh: 
 

Il s'agit maintenant d'attacher notre squelette à notre perso 3D. En soi, c'est assez simple, on sélectionne le bone voulu, on sélectionne ensuite les vertex autour 

et on les assigne au bone. 

Seulement, ça se complique parce que plusieurs bones peuvent influer sur les mêmes vertex, et donc il faut assouplir les pliures...  

 

 
 

Je passe le modèle en vue Wireframe et je coche les options ci-dessus pour pouvoir travailler: 

  _ La case cercle rouge affiche sur le Wireframe sur le modèle texturé, en mode Wireframe, elle ne sert à rien. 

  _ La case avec les 2 triangles rouge et vert permet d'afficher les vertex situés au dos du modèle 

  _ La case avec un os et une flèche (non cochée ci-dessus) permet d'afficher les assignements de vertex au bone sous forme de traits 

  _ La case avec l'os et les vertex rouge, bleu et vert permet d'afficher les vertex assignés au bone sélectionné 

  _ La case avec les 4 vertex permet d'afficher les vertex sur le modele 

  _ Enfin la case avec la tête de mort permet d'afficher le squelette  

 

Donc on va commencer par sélectionner les vertex, pour ce faire il y a une chose à retenir. 

Lorsque vous souhaitez sélectionner plusieurs vertex ou l'inverse: 

 

Click gauche   = sélection 

Click gauche + MAJ = sélection de plusieurs vertex en même temps 

Click gauche + ALT = désélection  

Click gauche + CTRL = sélection et désélection de l'inverse 

 

 

*Avant de commencer, sachez qu'il existe dans FragMotion une option AUTO ASSIGN VERTICE. 

Cette fonction peut vous permettre de gagner du temps (pour des tests d'animation rapides par exemple), FragMotion se chargera d'assigner automatiquement 

chaque vertex au bone le plus proche. 

 

ATTENTION ce sera loin d'être parfait, le rigging exige plus de précision car 2 bones peuvent influencer les mêmes vertex. 

Mieux vaut faire un rigging manuellement, mais ça demande plus de temps. 
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  A partir du panel Skeleton, je sélectionne le bone auquel je souhaite assigner les vertex. 

Je commence par le pied,je sélectionne R_Foot. 

Dans le panel TOOLS, cliquez ensuite sur le panneau déroulant, SELECT-> SELECT VERTEX 

Avec le click gauche, je sélectionne tous les vertex du pied, ils passent alors en mauve. Cliquez ensuite sur  dans la barre des tâches pour les assigner au 

bone. 
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La fenêtre suivante apparait:    

=>Assurez-vous que le bone voulu (R_Foot ici) soit bien sélectionné dans la case Bone ci-dessus ! 

Dans Weight = 0.000 mettez Weight = 1 et cliquez sur SET (le plus gros des 3).  

ça signifie que tous les vertex sélectionnés du pied seront assignés à 100% au bone R_Foot, ils passent donc en rouge (ça correspond également à la couleur de 

la jauge sous Weight). 

 

ATTENTION 

Dans la fenêtre d'assignement, assurez-vous que la case 'Adjust other weights' soit bien cochée, sinon mon exemple ne fonctionnera pas. 

Avec cette technique, on va se contenter d'assigner dans les grandes lignes et FragMotion recalculera en fonction du bone à proximité. 

On travaillera l'influence pour les articulations plus en détail juste après ça. 

 

*Comme je vous l'ai expliqué plus haut, il existe dans FragMotion une option AUTO ASSIGN VERTICE.  (Si vous ne voulez pas vous prendre, parce que 

cette partie est longue) 

Cette fonction peut éventuellement vous permettre de gagner du temps, en fonction de la pose par défaut de votre mesh, si les bones sont éloignés les uns des 

autres, ça peut être rapide car FragMotion se chargera d'assigner automatiquement chaque vertex au bone le plus proche. Mais ça ne sera pas parfait et vous 

courrez le risque d'avoir plus de choses à corriger au final. Ce sera à vous de tester. 
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Je sélectionne maintenant le bone du genou R_Knee et tous les vertex sous le genou jusqu'au pied. 

 
 

je refais la même chose j'assigne à 1.000 les vertex sélectionnés. 
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Je remonte au bone de la cuisse R_Leg (Dans le viewport, Clic molette pour  rafraichir.) 

   

 
     

En faisant attention de ne pas sélectionner des vertex de la jambe gauche. J'assigne à 1.000 

Maintenant on refait exactement la même chose pour la jambe gauche. 
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Ensuite on s'attaque au tronc. 

On sélectionne le bone du Pelvis et tous du bassin, on reste sous le nombril. 
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On sélectionne le bone Spin (colonne vertébrale) et on s'arréte sous la poitrine. 
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Ensuite le bone Chest, il faut être plus précis et bien faire attention à ne pas sélectionner les vertex des bones Shoulder (épaules) 
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Enfin le Bone Head auquel on assignera tous les vertex de la tête. 

Pour ce faire, je passe en vue de profil, c'est plus simple. 
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Même chose pour les bras, on sélectionne le bone de l'épaule droite R_Shoulder jusqu'au coude et on assigne à 1.000 

Normalement vous avez 2 lignes parallèles pour le pli au niveau du coude, vous sélectionnez les vertex jusqu'a la 1ere ligne comme ci-dessous 
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 Ensuite on sélectionne le bone R_Elbow (coude) jusqu'au poignet de la main, même chose pour le pli du poignet on s'arrête à la 1ere ligne  
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Enfin le bone R_Hand de la main et les vertex de la main. 

 



28 

 

Je termine par les doigts: 

c'est un peu particulier, en fonction de votre mesh. 
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Et pour les doigts, on sélectionne R_Fingers_end 

 

 
Et maintenant on refait exactement la même chose pour tout le bras gauche. 

Voila, vous savez comment attacher un squelette à votre mesh, maintenant peaufinons ! 
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4. Le weighting = poids des bones et influence 
 

Nous allons détailler le contenu de cette fenêtre: 

 

 
 

'Channel' sélectionne l'index du poids à assigner. ça peut être 1, 2, 3, 4 ou any. Quand any est sélectionné et qu'un assignement est fait sur un bone en cliquant 

sur 'Set',  l'assignement sera placé sur le 1er channel libre de chaque vertex. Comme on suppose que le poids total sera égal à 1.0, le 4éme channel assignera 

automatiquement un poids de 1.0 - (weight1 + weight2 + weight3). Si votre modèle nécessite un poids total différent de 1.0 alors vous ne devez pas utiliser le 

4éme channel. 

 

'Bone' affiche le bone sélectionné dans la vue 3d. Cette donnée peut être modifiée en sélectionnant un bone dans l'arbre de Skeleton ou en utilisant l'outil 

'Select Bone' dans la vue 3d. Selectionner le skeleton mettra cette valeur à '(none)'. Cliquez sur le bouton à côté 'Set' pour appliquer l'assignement du bone aux 

vertex sélectionnés dans l'index choisit de 'Channel'. 

 

'Weight' change l'influence du bone sur les vertex sélectionnés. Cliquez sur le bouton adjacent 'Set' appliquera ce poids aux vertex sélectionnés dans l'index 

choisi dans 'Channel'. Vous pouvez aussi Cliquer et déplacer le curseur dans la barre de couleur en dessous pour modifier le poids. 

NOTE: Cliquer sur le plus gros bouton 'Set' appliquera les 2, l'assignement aux bones ET le poids sur les vertex sélectionnés. 

 

Quand 'Adjust other weights' est coché, l'application des changements de poids mettra automatiquement à jour les autres valeurs pour chaque vertex 

proportionnellement de façon à ce que le poids total soit égal à 1.0. (ex: si un vertex a une valeur de poids {poids1=0.5, weight2=0.4, weight3=0.1 } et le poids 

1 change pour 0.25, alors le poids2 weight2= 0.6 et weight3 deviendra to 0.15) 

 



31 

 

Quand 'Show Highlighted Vertices' est coché alors tous les vertex assignés apparaitront en gros dans la couleur de leur valeur actuelle (ex: 1.0 = rouge). 

 

 
 

Si vous cochez 'Don't show this dialog again' et fermer la fenêtre, la prochaine fois l'assignement des vertex n'utilisera qu'un poids et vous ne pourrez plus 

faire de réglages avec cette fenêtre. Il faudra aller dans Edit/Edit Preferences, cliquer sur Edit et modifier la valeur 'VertexWeights' pour 4. 

 

Cliquer sur 'Deselect unhighlighed vertices' désélectionnera les vertex mis en évidence. 

 

Cliquer sur le bouton 'Advanced' affichera des options supplémentaires for mettre en évidence mes vertex sélectionnés à modifier. En advanced mode et 

quand n'importe quelle case est cochée, les changements faits sur l'assignement d'un bone ou son poids seront appliqués aux vertex mis en surbrillance. 
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Quand 'Weight is more than' est coché, seul les vertex dans le channel sélectionné qui ont un poids supérieur à la valeur adjacente seront sélectionnés. Vous 

pouvez modifier la valeur et cliquer sur 'Set'. 

 

Quand 'Weight is less than' est coché, seul les vertex dans le channel sélectionné qui ont un poids inférieur à la valeur adjacente seront sélectionnés. Vous 

pouvez modifier la valeur et cliquer sur 'Set'. 

 

Quand 'Vertex is influenced by' est coché, seul les vertex assignés au bone sélectionné dans la liste seront conservés. l'image ci-dessuus illustre l'idée. 
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a). Je commence par le pli des genoux, quand le genou va se plier, le côté mollet doit pénétrer dans le dos de la cuisse,  

 
Ces valeurs sont données à titre indicatif!!  Elles varieront en fonction de la modélisation de votre mesh, donc je ne m'attarderai pas dessus. 

Elles sont "inutiles" parce qu'elles sont liées à la modélisation de mon perso, mais elles peuvent vous servir d'exemple alors n'hésitez pas à faire plusieurs tests. 

Pour les vertex au milieu du genou. 

0.70 pour le bone du genou R_Knee 

0.30 pour le bone de la cuisse R_Leg 
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Et 0.50 / 0.50 pour le bone du genou et la cuisse, pour les 3 vertex au dessus du genou. 

Et on fait la même chose à gauche, comme d'habitude, PENSEZ BIEN à sélectionner L_Knee et L_Leg ! 
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(5. Tests pré-animation) 
Pour réaliser des petits tests rapides afin de vérifier la conception de votre maillage ou  l'influence des bones sur les vertex par exemple. 

Dans le panel à Droite, Onglet Animations, cliquez droit sur Animations comme ci-dessous -> New-> Animation (sans ça, aucun déplacement de bones ne 

sera possible) 

 
Ensuite en dessous dans le panel  TOOLS -> SKELETAL ANIMATION ->  Skeletal Anim Widget: 

On se retrouve avec un autre Widget, qui cette fois, va nous permettre de déplacer le bone avec le mesh attaché. 

 
Souvenez-vous si vous souhaitez déplacer ou faire pivoter un bone, il faudra respecter cet ordre en sélectionnant la couleur de l'axe en dernier 

Select Bone -> Translate ou Rotate Key -> Case Couleur 
Sinon, il y a l'inverse Kinematics ^^ 

Inverse Kinematics, parce qu'on va réaliser l'animation en contrôlant l'enfant (fin de la chaine des bones) et non le parent (début de la chaine). 

En d'autres termes, on déplace la main vers le haut, pour que le personnage lève le bras, au lieu de lui faire pivoter l'épaule. 

Sélectionnez alors un bone, maintenez le clic enfoncé, et déplacez-le en fonction du viewport et de l'angle de vue sélectionné. 
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Avec Fragmotion, vous avez même la possibilité de contrôler en temps réel l'influence des bones. 

Retournez sur votre nouvelle animation créée (si vous l'aviez quitté) 

Sélectionnez les vertex (TOOLS-> SELECT-> VERTEX) qui vous intéressent, cliquez sur  pour assigner les vertex et jouer avec le curseur sur la barre 

colorée, vous constaterez en direct l'influence des bones (bien sélectionnés au préalable) sur la déformation du mesh. 

 
 

b). Pour le pied 0.80 pour le bone genou R-Knee 

et 0.20 pour le bone pied R_Foot. 

ATTENTION: un 3eme bone pourrait se glisser dans la liste en cas d'erreur comme R_Leg ici, veillez à ce qu'il reste bien à 0.000, et que les 2 autres soient 

bien à 0.800 et 0.200 

On refait la même chose sur le pied gauche en sélectionnant les bones L_Knee et L_Foot 
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Pour retrouver la pose initiale du personnage, recliquez sur le Animations, le 1er de la liste! 

 

 c). On attaque la cuisse et les fesses 

 

On définit d'abord la partie fixe du bassin, concrètement quand le perso va lever la jambe ou s'assoir, le haut de sa cuisse doit rentrer dans le "bassin" 

Attention à bien sélectionner les 2 petits points isolés à droite et à gauche ! 

 
 

 



38 

 

De face, on sélectionne les vertex dans le pli de l'aine 
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Pour les fesses,  

1ere ligne du pli, on sélectionne les vertex ci-dessous 
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Seconde ligne du pli des fesses 

 
Testé, ça doit donner quelque chose comme ça, Les genoux et les fesses arrondis: 
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d). On attaque le tronc 

 
 

Mon perso porte un caleçon, les vertex de la peau sont à 50/50 liés avec le bone de la colonne (Pin) et du bassin (Pelvis) 

Le caleçon, lui, sera moins soumis à l'influence des bones donc  

0.70 pour le Pelvis 

0.30 pour Pin 
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Le torse nécessite peu d'ajustement, juste au niveau des hanches et du thorax 
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e). Maintenant on passe au cou 

Chest = 0.70 et Head = 0.30 
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f). Maintenant le plus compliqué, les épaules... 

L'amplitude des épaules est tellement importante presque 360°, qu'il est assez difficile d'obtenir quelque chose de complètement propre. 

Ma méthode de travail consiste à lever le bras du perso, ainsi je peux mieux définir l'influence de chaque bone sur les vertex au niveau du pli de l'épaule. 

 

Je clique sur bone Chest 

Dans le panel  TOOLS -> SKELETAL ANIMATION ->  je clique dans la seconde fenêtre sur Anchored (l'ancre) et Locked (la croix rouge) 

de façons à verrouiller le bone et empêcher toute rotation autour du bone Pelvis. 

 

 
 

 

Puis dans le Skeletal Animation Widget, je clique sur Inverse Kinematics 

 

 
 

 

En vue de face, je clique maintenant sur le bone de la main droite R_Hand et en maintenant appuyer, je le glisse vers la droite de façon à positionner le bras 

droite le long de la tête comme ci-dessous 
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Ensuite en vue 3D, on sélectionne le bone R_Shoulder, et on clique sur Rotate Key dans le Skeletal Animation Widget 

On fait pivoter le bras de cette façon, en sélectionnant l'axe de couleur rouge 
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Il va falloir jongler entre cette fausse séquence d'animation et la pose initiale du perso, pour sélectionner les vertex et modifier l'influence des bones.  

 
Pensez à bien tester l'animation bras levé et bras baissé le long du corps pour obtenir le rendu le plus réaliste et plus propre possible. 
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g). On passe au coude, tout l'avant bras est assigné au bone du coude jusqu'au poignet (le dessus traversera le biceps quand le bras sera plié) 

On modifie l'influence très légèrement sur le coude comme ci-dessous pour "l'arrondir". 
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Pensez bien à refaire exactement la même chose à gauche comme d'habitude. 

 

Enfin testez et re-testez différentes positions jusqu'à l'obtention de quelque chose de propre et "d'arrondi sur les angles". 

Pied, genou, épaule, coude, poignet, main et cou. 

 

 

 
Terminé! 

On peut maintenant passer à l'animation du personnage. 
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C. L'ANIMATION 
  

Pour ceux qui ont déjà modélisé quelque chose en 3D, vous comprendrez aisément le système. 

On va procéder en 2 étapes: 

 

1) Référence: 

Quand on modélise en 3D on doit utiliser ce qu'on appelle des Gabarits ou Blueprint: 

 
On utilise ce gabarit comme référence en arrière-plan et on modélise en déplaçant les vertex d'abord de face, puis de profil, pour les faire correspondre au 

modèle, ainsi en étant travaillé e face et de profil, le mesh prendra petit à petit la forme du gabarit. 

On fera de même pour l'animation, afin d'obtenir quelque chose de propre, on calquera les mouvements d'une référence précise. 

 

2) Optimisation 

Toujours comme pour la 3D, on va commencer par travailler sans se soucier du nombre de clef d'animation total (Keyframes) 

On va se contenter dans un premier temps de calquer tous les mouvements pour rendre l'animation la plus réaliste possible. 

 

Ensuite, on va optimiser ; en 3D on travaille d'abord sans se soucier du nombre de faces, on suit le gabarit pour détailler le modèle au maximum, puis on 

travaille en LPM (Low Poly Modelisation), manuellement on va réduire le nombre de faces en essayant de conserver la "forme originale" du modèle 3D, en 

évitant que ce soit trop carré. On doit faire beau avec très peu de faces.  

Pour l'animation, on essaiera de faire pareil, on ne conservera que les étapes essentielles du mouvement et on supprimera les clefs inutiles. 
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Dans le panel à Droite, Onglet Animations, cliquez droit sur Animations comme ci-dessous -> New-> Animation  

 

 
Puis double-cliquer sur cette nouvelle Animation pour ouvrir le Keyframe Editor 

 

 
 

Il affichera les clefs d'animation pour chaque bone, gardez à l'esprit que plus il y aura de clefs d'animation, plus ce sera lourd à charger pour RealmCrafter ! 

Le perso par défaut de RCS compte 1539 frames au total, je conseille de rester en dessous des 500-600 au total. 
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A SAVOIR: 

 

 

_ Les Clefs d'animation ou Keys sont automatiquement enregistrées sur le curseur rouge Current Frame, donc faites attention à bien le repositionnez à chaque 

fois 

 

_ Clic gauche dans la barre bleue (Grid Header) permet de positionner le curseur rouge Current Frame 

 

_ Clic droit dans la barre bleue (Grid Header) permet de sélectionner toutes les Keys de la colonne 

 

_ Quand les Keys passent en bleue (au lieu de jaune) c'est qu'elles sont sélectionnées 

 

_ Quand toutes les keys sont sélectionnées, placez dessus un curseur en forme de main apparaitra et vous permettra de déplacer les Keys 

 

_ Dans la barre bleue (Grid Header) La flèche à droite de 20, permet d'allonger la durée de l'animation  

 

_ Si vous sélectionnez une colonne de Keys et utilisez les outils copier/coller, sachez que FragMo ne colle pas les keys là où vous avez positionné votre curseur, 

Il pose la copie sur le frame 1, à vous ensuite de déplacer la colonne copiée avec le curseur main 

 

_ Pour boucler parfaitement votre animation, copiez le 1er frame et créez le dernier frame avec cette copie 
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1. IK = Inverse Kinematics : 
Inverse Kinematics = parce qu'on va réaliser l'animation "de façon inverse", ce qui signifie plutôt en partant de la fin. 

On va contrôler directement l'enfant (donc fin de la chaine des bones) pour qu'ils dirigent le bone parent (début de la chaine). 

En d'autres termes, pour faire lever le bras du perso, on va déplacer directement la main vers le haut et elle va entrainer tout le bras (je sais, ça nous parait 

logique, mais pour un ordinateur ça ne l'est pas ^^), au lieu de lui faire pivoter d'abord l'épaule, puis le coude, puis le poignet et enfin la main... 

 

Dans le panel  TOOLS -> SKELETAL ANIMATION ->  Skeletal Anim Widget: 

On retrouve notre Widget. 

 

On va d'abord choisir la bonne caméra en fonction du mouvement souhaité. On peut commencer avec celle de face par exemple pour faire descendre le bras le 

long du corps. 

 

 

 
 

 

On va d'abord verrouiller le bone Chest, au niveau du thorax, pour ne pas que le reste du corps soit entrainé avec le bras. On le sélectionne. 

Dans la seconde fenêtre qui est apparue avec le Widget d'animation, on clique sur Anchor puis sur Locked. 

 

 

On clique sur le bone R_hand, puis sur Inverse Kinematics. 

Maintenez le clic enfoncé, et déplacez-le en fonction du viewport et de l'angle de vue sélectionné. 

Et amenez le poignet le long du corps, comme sur l'image ci-dessous 
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2. Animation de marche: 
 Pour les persos il faut un minimum de clés d'animation ou KeyFrames. C'est surtout ça qui fait ramer Blitz! 

Ce n'est pas la durée de l'animation, ni le nombre de tris/faces mais bien le nombre de clés d'animation. 

Donc le mieux c'est de fonctionner par poses-clés (en gros : ne créer des clés qu'aux étapes essentielles, et toutes les 5 frames par exemple). 

 
Nous allons donc animer un cycle de marche, on renomme vite fait l'animation: Walk 

Pour ce faire, nous allons avoir besoin de chercher des références sur le web 

Voici celle que j'utilise pour la vue de profil: 
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On va donc l'utiliser en Background dans FragMotion 

Dans la barre d'options -> View -> Background Images 

 

 
 

_ On doit choisir la vue, donc je clique sur Left (profil gauche), de façon à ce que mon personnage soit dans la même position que celui de référence 

 

_ Puis on clique sur Browse... et on charge son image référence, en prenant soin de sélectionner le format de l'image dans la liste en bas à droite. 

 

_ Avec Scale, on ajuste la taille de l'image 

 

_ et avec les Offsets X et Y, on ajuste la position de l'image, puis Done pour valider 
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Maintenant je double-clique sur mon animation pour ouvrir le Keyframe editor 

Dans la barre bleue, je place ensuite le curseur rouge sur le Frame 2, on laisse le Frame 1 libre pour pouvoir exporter plus facilement le squelette ensuite. 

Donc je commence à positionner mon personnage de la même façon que sur ma référence, j'utilise Inverse Kinematics et je fais bien attention au bone que je 

sélectionne. 

 

FRAME1: 

 

Pensez à basculer en vue Wireframe pour voir par transparence et adapter la position de votre personnage. 

Ne négligez aucun détail, vérifiez la position des épaules, du nez (pour la hauteur, je me base sur la position du nez) de la tête etc... Afin que ce soit le plus 

réaliste possible. 

 

Quand vous travaillez avec  TOOLS -> SKELETAL ANIMATION ->  Skeletal Anim Widget: 

En dessous une fenêtre  INVERSE KINEMATICS TOOLS apparait: 

Avec une option de CONSTRAINTS, LockX, LockY et LockZ, pensez à cocher/décocher pour travailler en fonction des axes 

 

False = le mouvement sera libre sur cet axe 

True = le mouvement sera bloquer sur cet axe 

 

Frame 5: 

 Le 1er mouvement est posé, dans la barre bleue du KeyFrame editor je déplace le curseur sur 6 puis dans View -> Background images 

Je modifie Offset X, de façon à caler la seconde position de l'animation sur mon perso. 

On repasse en vue Wireframe pour repositionner le perso. 

 

Quand j'anime les jambes, je verrouille le bone Pelvis, au niveau du bassin, sinon le reste du corps sera entrainé. On le sélectionne. 

Dans la seconde fenêtre qui est apparue avec le Widget d'animation, on clique sur Anchor puis sur Locked. 

Quand j'anime les bras, je verrouille Chest ou Pin. 

 

Frame 9:  
Le 2eme mouvement est posé, dans la barre bleue du KeyFrame editor je déplace le curseur sur 10 puis dans View -> Background images 

Je modifie Offset X, de façon à caler la seconde position de l'animation sur mon perso. 

 

etc.. pour le Frame 13 et 17, on a calqué les 5 poses de la référence. 
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 Effet MIROIR:  

 

Comme ils ne sont pas présents sur l'image référence: 

 

Frame 21: 

Il correspond au Frame 5 (mais les bras et jambes sont à l'inverse), Vous copiez le frame 6, collez et déplacez sur le frame 22, dans le KEYFRAME EDITOR 

=> Pose puis => flip current pose. 

Vous obtiendrez la position inverse de celle copiée. 

 

 

Frame 25: correspond au frame 9 (mais les bras et jambes sont à l'inverse) 

 

Frame 29: correspond au frame 13 (mais les bras et jambes sont à l'inverse) 

 

et pour le dernier Frame 33, on copie/colle simplement le 1er Frame (Frame 1 donc) 

 

On réalise donc 9 Frames en tout (en sachant que le dernier est une copie du 1er pour créer une boucle) 

Maintenant que le personnage est animé de profil, on va l'animer de face. 

Voici celle que j'ai bidouillé et que j'utilise pour la vue de face: 
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On retourne dans View -> Background Images 

 



59 

 

 
 

_ Vue de face (Attention comme j'utilise un .X, c'est inversé dans FragMotion) donc Back 

_ Puis Browse... on charge son image référence. 

_ Et on ajuste avec Scale et les Offsets X et Y, puis Done pour valider 

 

 

Maintenant je double-clique sur mon animation pour ouvrir le Keyframe editor 

Dans la barre bleue, je place ensuite le curseur rouge sur le Frame 2. 

Et je rebascule en mode Wireframe, et je recommence à positionner mon personnage de la même façon que sur ma référence. 

 

 

Le 1er mouvement est posé, dans la barre bleue du KeyFrame editor je déplace le curseur sur 6 puis dans View -> Background images 

Je modifie Offset X, de façon à caler la seconde position de l'animation sur mon perso. 

On repasse en vue Wireframe pour repositionner le perso et on fait comme ça pour tout le reste. 

 

Astuce: 

On travaillera l'animation RUN à partir de l'animation WALK 

Pour cela on clique droit sur l'animation puis DUPLICATE ANIMATION et on renomme 

La course compte 12 frames de 1 à 24 (séparé par 1 frame à chaque fois) 

Voila votre personnage est animé! 

 

 



60 

 

 

Maintenant on va supprimer quelques Frames pour alléger le fichier, ciblons les moins utiles: 

3. Export en .B3D: 
 

Une fois toutes les animations terminées, cliquez sur File -> Export et choisissez le 2nd format de la liste: BlitzBasic 3D File (.b3d) 

Pour obtenir la liste de vos Frames, KeyFRAME Editor => EDIT => APPEND ANIMATION, il vous crée un fichier .txt à recopier dans LA GUE 

Toujours par souci d'optimisation, il faut éviter que ce fichier Actor pèse trop lourd, c'est important pour éviter le lag. 

         BlitzBasic supporte très peu de clef d'animation ! 

         La taille du fichier Actor est responsable du "loading lag" = chaque fois qu'un perso entre sur une map, RC lag!  

          Plus de bones animés = Plus à updater pour le serveur = Réponses plus longues = Lag en jeu. 
          Le perso fournit avec RC met presque 3 secondes à charger ! Imaginez avec 10 persos comme ça sur la map... 

        Dans l'écran Création de personnage, cliquez sur le perso, le temps qu'il mettra à apparaitre ici, sera le même en jeu, donc si c'est trop long => lag 

        ingame... 

       Assurez-vous pour qu'il pèse au maximum  200 ko ! 
      Pour vous donner un ordre d'idée: 
 

Perso RC par défaut Mon perso 

1308 faces (sans armure) 

2 textures 512x512, Head et Body, en .png 

32 bones (5 bones inutiles, normalement 27) 

32 Séquences animées 

1539 Frames au total (32 seq de 48 Frames) 

1.10 mo en .B3D (1.93mo encrypté en .eb3d) 

Temps de chargement = 3 Secondes !!! 

1636 faces 

512x512 body et 256x256 Head, en .dds 

20 bones 

30 Séquences animées 

1020 Frames au total (30 seq de 34 Frames) 

88 ko en .B3D 

Temps de chargement = 0 !!! 
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4. Export squelette et anims: 
Vous pouvez également exporter votre squelette et toutes ses animations pour l'intégrer sur un nouveau mesh. 

1) On s'assure qu'aucun bone ne soit sélectionné (pour ne pas risquer de le supprimer): 

les bones sélectionnés sont en vert. 

TOOLS -> SELECT -> SELECT BONE:  
On clique sur le model et CTRL+ MAJ+ N (ou on peut aussi cliquer dans le vide pour tout désélectionner) 

 

2) On supprime le Mesh:  

Dans le panel ANIMATIONS -> onglet MODEL: 

On sélectionne MESH et on fait CTRL + A 

Le mesh entier passe en rouge, on clique sur Suppr 

 

3) Seul les squelette reste: 

On recompte tous les bones pour être sûr qu'il ne manque rien et on sauvegarde le squelette sous un autre nom 

File ->Save as -> Skeleton.ugh 

 

4) Ensuite vous pouvez revenir sur votre mesh avec CTRL+Z ou la flèche UNDO 

Le mesh réapparait en rouge, cliquez sur CTRL+MAJ+N pour le désélectionner et sauvegardez votre perso 

File ->Save as -> Character.ugh 

 

5) On peut également diviser ou fusionner toutes les séquences d'animation, et récupérer les durées de séquences dans un document texte.  

Ouvrez Key Editor (double click animation) ->Edit -> Append animations... (ou Split si vous souhaitez les diviser) 

 
5. Import: 
Pour importer votre squelette avec toutes ses animations sur un nouveau mesh, chargez d'abord votre mesh. 

File -> Open -> NewCharacter 

(N'oubliez pas de cliquer droit dans votre fenêtre pour la rafraichir pour que les mesh apparaisse) ;) 

 

Ensuite pour charger votre squelette avec toutes ses animations 

File -> MERGE -> Skeleton.ugh 

 
Et voila votre squelette apparait sur votre perso, il ne vous reste plus qu'à tout attacher à votre nouveau mesh 

(cf. Chapitre B partie 3: Attacher le squelette au mesh)  

 
En espérant que ça vous aide, n’hésitez pas à me contacter par mail ou par MP sur le forum de RC France. 

Giuliani Terrier pour RealmCrafter France Aout 2013 


